WooCommerce Vulnerability Affects Millions of WordPress Sites

Jovani

Active member
Joined
Jul 10, 2012
Messages
330
Points
28
A new article on Search Engine Journal here reports that WooCommerece just announced a patch for a critical vulnerability that is rolling out as a forced update. Publishers have been urged to check if they're updated.

WooCommerce has just announced it has patched a critical vulnerability affecting millions of users. Publishers using the WooCommerce plugin or the WooCommerce Blocks plugin are strongly urged to update their plugins if they have not already automatically updated.

"On July 13, 2021, a critical vulnerability concerning WooCommerce and the WooCommerce Blocks feature plugin was identified and responsibly disclosed by security researcher Josh via our HackerOne security program.
Upon learning about the issue, our team immediately conducted a thorough investigation, audited all related codebases, and created a patch to fix the issue for every impacted version (90+ releases), which was deployed automatically to vulnerable stores."
If you have a WooCommerce store, automatic software updates began rolling out on July 14, 2021, to all stores running impacted versions of each plugin. It's recommended you ensure that you're using the latest version. For WooCommerce, this is 5.5.1 or the highest number possible in your release branch. If you're also running WooCommerce Blocks, you should be using version 5.5.1 of that plugin.

After updating to a patched version, the company also recommends:
Updating the passwords for any Admin users on your site, especially if they reuse the same passwords on multiple websites
Rotating any Payment Gateway and WooCommerce API keys used on your site.

If your website didn't get the automatic update, That could be for a number of reasons, a few of the most likely are: you're running a version prior to one impacted (below WooCommerce 3.3), automatic updates have been explicitly disabled on your site, your filesystem is read-only, or there are potentially conflicting extensions preventing the update. In all cases (except the first example, where you are unaffected), you should attempt to manually update to the newest patched version on your release branch (e.g. 5.5.1, 5.4.2, 5.3.1, etc.)
 
Older threads
Replies
9
Views
589
Replies
0
Views
350
Replies
5
Views
475
Latest threads
Replies
0
Views
7
Replies
1
Views
38
Replies
6
Views
68
Replies
8
Views
94

Latest postsNew threads

Referral contests

Referral link for :

Sponsors

Latest Blog ArticlesMost Viewed Threads

Popular tags

You are using an out of date browser. It may not display this or other websites correctly.
You should upgrade or use an alternative browser.

Top