Error when installing wordpress plugin/theme on VPS?

Jovani

Active member
Joined
Jul 10, 2012
Messages
335
Points
28
My wordpress blog is working well on my VPS but today I try to install a new theme and a new plugin for it, it showed error below
To perform the requested action, WordPress needs to access your web server. Please enter your FTP credentials to proceed. If you do not remember your credentials, you should contact your web host.
and I coudn't install WP theme/plugin for my blog

how to solve this?
Please support
 

hoangvu

New member
Joined
Jun 6, 2012
Messages
1,872
Points
0
In the process of using WordPress on your VPS, you can see the errors related to read/write data when installing plugin/theme as you mentioned in your question.
The reason this happens is due to errors in web server (nginx or apache) is not permission to read/write/delete or edit data. You will need to Cd (move) to your directory where you are storing data (eg /home/yourdomain.com/public_html/) and run the following command:

For Nginx on CentOS
Code:
chown -R nginx:nginx *
For Apache on CentOS
Code:
chown -R apache:apache *
For Nginx on Ubuntu
Code:
chown -R www-data:www-data *
For Apache on Ubuntu
Code:
chown -R www-data:www-data *
Hope it helps!
 
Newer threads
Latest threads
Replies
1
Views
25
Replies
4
Views
29
Replies
2
Views
22
Replies
2
Views
33

Referral contests

Referral link for :

Sponsors

Popular tags

You are using an out of date browser. It may not display this or other websites correctly.
You should upgrade or use an alternative browser.

Top